package visa.openplatform ;

public class OPSystem{
    public static final byte APPLET_SELECTABLE = (byte) 0 ;
    public static final byte APPLET_PERSONALIZED = (byte) 1 ;
    public static final byte APPLET_BLOCKED = (byte) 2 ;

    public static byte getCardContentState();

    public static boolean setCardContentState(byte state);

    public static boolean verifyPin  (javacard.framework.APDU apdu , byte pin);
    
    public static byte getTriesRemaining();
}